[graalvm-users] Testing polyglot libs

Rodrigo Botafogo rodrigo.a.botafogo at gmail.com
Thu Jun 14 08:25:56 PDT 2018


I'm trying to set up testing for my polyglot lib and I'm having a hard
time.  Sorry if I should post somewhere else...

So I tried to test with rspec, but rspec will run ruby somehow and does not
pass to ruby the --polyglot --jvm flags.  Polyglot complains that R is not
a known language.  I've googled around and could not find an easy way to
make rspec pass flags to ruby.

Next I tried minitest, since in this case I call ruby directly with the
required flags... but polyglot complains that R cannot execute in
multithreaded, so I passed -Xsingle_threaded to ruby and minitest complains
that it only runs in a multithreaded environment.

Any suggestions how to move forward?


Rodrigo Botafogo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://oss.oracle.com/pipermail/graalvm-users/attachments/20180614/9a181710/attachment.html 

More information about the GraalVM-Users mailing list