[Ocfs-users] OCFS install trouble w/ new kernel - unresolved symbols

Sunil Mushran Sunil.Mushran at oracle.com
Tue Mar 30 12:58:16 CST 2004

Last I heard, Redhat had desupported the drivers for
QLogic 2310 on RHEL3.

The unresolved symbol issue can be resolved by
rebuilding ocfs with the patched kernel.
1. untar ocfs.
2. ./autogen --with-kernel=<path to the kernel>
3. make KVER=[up, smp]

Mind you, this (as in the personally built modules)
is not officially supported by Oracle.


benwood1 at airmail.net wrote:

>I successfully have OCFS running in a two-node RAC environment using RHAS
>3 (2.4.21-4.EL) using Qlogic 2310 cards.  IO performance, however, was
>terrible with the combination of OCFS and the Qlogic cards.  After
>extensive testing, OCFS did fine on its own, as did the fibre cards.  Put
>the two together, and everything literally ran twice as slow.
>Support at Qlogic pointed me to
>http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=104633, where there is
>a test kernel that might resolve the problem (2.4.21-9.EL.noaffine2BOOT).
>I installed the kernel and re-installed OCFS.  Though I tried the OCFS
>RPMs, building OCFS from the source RPMs, and compiling from source code,
>doing a “load_ocfs” gets me a mismatched kernel messages, followd by a
>long list of unresolved symbols.
>(proc_mkdir_Rab0b93e0, find_or_create_page, etc).  I’ve tried using
>ocfs-2.4.21-EL-1.0.10-1.i686.rpm, ocfs-2.4.21-EL-1.0.11-1.i686.rpm,
>ocfs-2.4.21-EL-1.0.9-12.src.rpm, and ocfs-1.0.10.tar.gz.tar.
>Any suggestions/ideas?
>Many thanks,
>Benjamin Wood
>General Dynamics
>Ocfs-users mailing list
>Ocfs-users at oss.oracle.com

More information about the Ocfs-users mailing list