[Ocfs-users] OCFS install trouble w/ new kernel - unresolved symbols

benwood1 at airmail.net benwood1 at airmail.net
Tue Mar 30 14:33:12 CST 2004

I successfully have OCFS running in a two-node RAC environment using RHAS
3 (2.4.21-4.EL) using Qlogic 2310 cards.  IO performance, however, was
terrible with the combination of OCFS and the Qlogic cards.  After
extensive testing, OCFS did fine on its own, as did the fibre cards.  Put
the two together, and everything literally ran twice as slow.

Support at Qlogic pointed me to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=104633, where there is
a test kernel that might resolve the problem (2.4.21-9.EL.noaffine2BOOT).
I installed the kernel and re-installed OCFS.  Though I tried the OCFS
RPMs, building OCFS from the source RPMs, and compiling from source code,
doing a “load_ocfs” gets me a mismatched kernel messages, followd by a
long list of unresolved symbols.
(proc_mkdir_Rab0b93e0, find_or_create_page, etc).  I’ve tried using
ocfs-2.4.21-EL-1.0.10-1.i686.rpm, ocfs-2.4.21-EL-1.0.11-1.i686.rpm,
ocfs-2.4.21-EL-1.0.9-12.src.rpm, and ocfs-1.0.10.tar.gz.tar.

Any suggestions/ideas?

Many thanks,
Benjamin Wood
General Dynamics

More information about the Ocfs-users mailing list