[El-errata] ELSA-2012-0301 Low: Oracle Linux 5 ImageMagick security and bug fix update

Errata Announcements for Oracle Linux el-errata at oss.oracle.com
Wed Mar 7 15:36:52 PST 2012


Oracle Linux Security Advisory ELSA-2012-0301

https://rhn.redhat.com/errata/RHSA-2012-0301.html

The following updated rpms for Oracle Linux 5 have been uploaded to the 
Unbreakable Linux Network:

i386:
ImageMagick-6.2.8.0-12.el5.i386.rpm
ImageMagick-c++-6.2.8.0-12.el5.i386.rpm
ImageMagick-c++-devel-6.2.8.0-12.el5.i386.rpm
ImageMagick-devel-6.2.8.0-12.el5.i386.rpm
ImageMagick-perl-6.2.8.0-12.el5.i386.rpm

x86_64:
ImageMagick-6.2.8.0-12.el5.i386.rpm
ImageMagick-6.2.8.0-12.el5.x86_64.rpm
ImageMagick-c++-6.2.8.0-12.el5.i386.rpm
ImageMagick-c++-6.2.8.0-12.el5.x86_64.rpm
ImageMagick-c++-devel-6.2.8.0-12.el5.i386.rpm
ImageMagick-c++-devel-6.2.8.0-12.el5.x86_64.rpm
ImageMagick-devel-6.2.8.0-12.el5.i386.rpm
ImageMagick-devel-6.2.8.0-12.el5.x86_64.rpm
ImageMagick-perl-6.2.8.0-12.el5.x86_64.rpm

ia64:
ImageMagick-6.2.8.0-12.el5.ia64.rpm
ImageMagick-c++-6.2.8.0-12.el5.ia64.rpm
ImageMagick-c++-devel-6.2.8.0-12.el5.ia64.rpm
ImageMagick-devel-6.2.8.0-12.el5.ia64.rpm
ImageMagick-perl-6.2.8.0-12.el5.ia64.rpm


SRPMS:
http://oss.oracle.com/ol5/SRPMS-updates/ImageMagick-6.2.8.0-12.el5.src.rpm


Description of changes:

[6.2.8.0-12.el5]
- Add fix for CVE-2010-4167 (767142)

[6.2.8.0-11.el5]
Fix assertion failed when using "identify -verbose" when there's no
   image information available (502626)

[6.2.8.0-10.el5]
Fix memory allocation failure when using color option (616538)
   Fix hang when converting broken GIF (693989)
   Fix conversion of rotated landscape PDF (694922)

[6.2.8.0-9.el5]
Fix a deadlock with semaphore (530592)

[6.2.8.0-8.el5]
- Fix page size argument parsing (580535)

[6.2.8.0-7.el5]
- Fix SGI image decoding (498063)

[6.2.8.0-6.el5]
- Add fix for CVE-2009-1882 (504305)

[6.2.8.0-5.el5]
- update quantum memory patch (necessary for CVE fixes)
- backport functionality for SetImageExtent (necessary for CVE fixes)
- Add patch for CVE-2008-1096 (#286411)
- Add patch for CVE-2008-1097 (#285861)
- update patch for CVE-2007-4986




More information about the El-errata mailing list