[El-errata] ELSA-2009-1083 Important: Enterprise Linux 4 cups security update

Errata Announcements for Enterprise Linux el-errata at oss.oracle.com
Wed Jun 3 16:35:38 PDT 2009


Enterprise Linux Security Advisory ELSA-2009-1083

https://rhn.redhat.com/errata/RHSA-2009-1083.html

The following updated rpms for Enterprise Linux 4 have been uploaded to 
the Unbreakable Linux Network:

i386:
cups-1.1.22-0.rc1.9.32.el4_8.3.i386.rpm
cups-devel-1.1.22-0.rc1.9.32.el4_8.3.i386.rpm
cups-libs-1.1.22-0.rc1.9.32.el4_8.3.i386.rpm

x86_64:
cups-1.1.22-0.rc1.9.32.el4_8.3.x86_64.rpm
cups-devel-1.1.22-0.rc1.9.32.el4_8.3.x86_64.rpm
cups-libs-1.1.22-0.rc1.9.32.el4_8.3.i386.rpm
cups-libs-1.1.22-0.rc1.9.32.el4_8.3.x86_64.rpm

ia64:
cups-1.1.22-0.rc1.9.32.el4_8.3.ia64.rpm
cups-devel-1.1.22-0.rc1.9.32.el4_8.3.ia64.rpm
cups-libs-1.1.22-0.rc1.9.32.el4_8.3.i386.rpm
cups-libs-1.1.22-0.rc1.9.32.el4_8.3.ia64.rpm

SRPMS:
http://oss.oracle.com/el4/SRPMS-updates/cups-1.1.22-0.rc1.9.32.el4_8.3.src.rpm

Description of changes:

[1:1.1.22-0.rc1.9.32:.3]
- Updated patch to fix CVE-2009-0791 to treat also cases
  gmalloc(int C + int nObjs * int objSize) (bug #491840).

[1:1.1.22-0.rc1.9.32:.2]
- Applied patch to fix CVE-2009-0949 (bug #500972).

[1:1.1.22-0.rc1.9.32:.1]
- Applied patch to fix CVE-2009-0791 (bug #491840).
- Applied patch to fix CVE-2009-1196 (bug #497135).




More information about the El-errata mailing list