[Ocfs2-commits] mfasheh commits r2187 - trunk/fs/ocfs2

svn-commits at oss.oracle.com svn-commits at oss.oracle.com
Tue Apr 26 22:22:12 CDT 2005


Author: mfasheh
Signed-off-by: manish
Date: 2005-04-26 22:22:10 -0500 (Tue, 26 Apr 2005)
New Revision: 2187

Modified:
   trunk/fs/ocfs2/namei.c
Log:
* replace the #warning in ocfs_rename with a simple comment.

Signed-off-by: manish



Modified: trunk/fs/ocfs2/namei.c
===================================================================
--- trunk/fs/ocfs2/namei.c	2005-04-27 03:17:45 UTC (rev 2186)
+++ trunk/fs/ocfs2/namei.c	2005-04-27 03:22:10 UTC (rev 2187)
@@ -1010,7 +1010,6 @@
  */
 static int ocfs_rename (struct inode *old_dir, struct dentry *old_dentry, struct inode *new_dir, struct dentry *new_dentry)
 {
-#warning "this needs to be split up into seperate functions."
 	int status = 0;
 	struct inode *old_inode = old_dentry->d_inode;
 	struct inode *new_inode = new_dentry->d_inode;
@@ -1031,6 +1030,9 @@
 						    // this is the 1st dirent bh
 	nlink_t old_dir_nlink = old_dir->i_nlink, new_dir_nlink = new_dir->i_nlink;
 
+	/* At some point it might be nice to break this function up a
+	 * bit. */
+
 	mlog_entry ("(0x%p, 0x%p, 0x%p, 0x%p, from='%.*s' to='%.*s')\n",
 			old_dir, old_dentry, new_dir, new_dentry,
 			old_dentry->d_name.len, old_dentry->d_name.name,



More information about the Ocfs2-commits mailing list